Login Failed

Invalid login/password combination. You may wish to or


We could not find any active order with id or e-mail mentioned. Try again

Customer Login

Order Id / E-mail

Password Reminder

Enter your E-mail or Order Id. After clicking submit button check you e-mail box for further instructions.
Order Id / E-mail
Cart (empty)

GFI EndPointSecurity 2012

  • en
PC Software
$19.95 RRP $39.90 Add to Cart


The proliferation of consumer devices such as iPods, USB devices, Smart Phones and more, has dramatically increased the risk of intentional and unintentional data leaks and other malicious activity. While most companies have anti-virus software, firewalls, email and web content security to protect against external threats, few realize how easy it is for an employee to simply walk in and copy large amounts of sensitive data onto an iPod or USB stick. There is also an increased risk of malicious and other illegal software introduction to your network through these devices. Of course your administrator could lock down all ports, an ill-advised, difficult and unsustainable solution.


  • Control user access and protect your network against the threats posed by portable storage media
  • Log the activity of portable storage media like USB memory sticks, SD cards and more
  • Easily configure group-based protection control via Active Directory
  • Advanced granular access control, whitelists and blacklists
  • Real-time status monitoring and real-time alerts
  • Other Features
  • Tamper-proof agent
  • Easy unattended agent deployment
  • Permit temporary device access
  • Scan and detect a list of devices that have been used or are currently in use
  • Password protected agents to avoid tampering
  • Set up custom popup messages for users when they are blocked from using a device
  • Browse user activity and device usage logs through a backend database
  • Maintenance function that allows you to delete information that is older than a certain number of days
  • Support for operating systems in any Unicode compliant language

System Requirements

  • Windows 2000/XP/2003/Vista/2008/7/2008R2/8/2012
  • .Net Framework 2.0
  • SQL Server 2000, 2005, 2008