Login Failed

Invalid login/password combination. You may wish to or

Error

We could not find any active order with id or e-mail mentioned. Try again

Customer Login

Order Id / E-mail
Password
Login

Password Reminder

Enter your E-mail or Order Id. After clicking submit button check you e-mail box for further instructions.
Order Id / E-mail
Submit
Cart (empty)

Autodesk AutoCAD LT 2014 (64-bit)

  • en
  • zh
  • cs
  • fr
  • de
  • hu
  • it
  • ko
  • pl
  • pt
  • ru
  • es
PC Software
SEE ALL
$199.95 RRP $1,200.00 Add to Cart

Overview

The professional choice for drafting software

Document your designs with the intuitive tools of Autodesk® AutoCAD LT® drafting software for PC and Mac. Produce precise 2D CAD drawings that you can easily edit, repurpose, and share.

Speed design documentation with Autodesk® AutoCAD LT® 2014 2D drafting software, now on Windows® 8. Drive stakeholder involvement with design feed social collaboration tools, and connect your designs to real-world environments with live maps and geolocation capabilities. And with dozens of time-saving enhancements, AutoCAD LT streamlines your design workflow.

Features

  • Live maps
  • Connect your design to real-world environments.
  • Design feed
  • Design feed encourages social collaboration.
  • File tabs
  • Improve your design productivity with file tabs.
  • Intelligent command line (enhanced)
  • Get autocorrect and adaptive/synonym suggestions.
  • Associative arrays
  • Associative arrays can simplify design workflow.

System Requirements

  • Windows 8 Standard, Enterprise, or Professional edition, Windows 7 Enterprise, Ultimate, Professional, or Home Premium edition, or Windows XP Professional edition (SP2 or later)
  • AMD Athlon™ 64 with SSE2 technology, AMD Opteron™ processor with SSE2 technology, Intel® Xeon® processor with Intel EM64T support with SSE2 technology, or Pentium 4 with Intel EM64T support with SSE2 technology
  • 2 GB RAM
  • 4 GB free disk space for installation
  • 1,024 x 768 VGA display with true color
  • Internet Explorer 7.0 or later